Your Windows user is not authorized to use ControlUp (On-Premises Login Issue)
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    Your Windows user is not authorized to use ControlUp (On-Premises Login Issue)

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    Article Summary

    Issue

    You try to login to the On-Premises ControlUp Real Time Console and receive an error - "Your Windows user is not authorized to use ControlUp" (or the error might be Black Screen instead of splash screen) en-usarticleattachments205340705image0013.png

    Root Cause

    The issue might be caused by several reasons.
    To receive more details about the failure, you can look at the login log which is located on the On-Premises server in:
    C:\Program Files\Smart-X\ControlUp Server\Websites\UserManagementService\4.1_WS\user management.log

    The cause of this issue might be one of the following:

    1. License issue -
      If the number of members in the authorized group, defined during the On-Premises server application wizard, as the group which contains the AD users which are allowed to login to ControlUp, cross the number of admins in the license, you will receive this error.
    2. AD user or group issue -
      • The AD user is not part of the authorized group.
      • The group or its SID was changed manually in the settings file.
      • The AD Group type is universal and not global.
    3. Setup Issue -
      The authentication method in the IIS is incorrect.

    Solution

    1. License Issue - As mentioned, the error might indicate the number of members in the authorized AD group is higher than the license permits (The error might be a black screen instead of splash screen).

      To verify the number of users if the authorized group match the license limit, please follow these steps:

      • Check the license quantity:

        On the On-premises server, navigate to - * C:\Program Files\Smart-X\ControlUp Server\Server Settings<LicenseFileName>.XML* In the following example, the quantity is unlimited.en-usarticleattachments205298269OnPremisesLicense.png

      • Check which group you defined during the installation (if you do not remember):

        On the On-premises server, go to - C:\Program Files\Smart-X\ControlUp Server\Server Settings\ControlUpServerSettings.XML en-usarticleattachments205341205GroupandSID.png

      • Check the license locationand name:

        en-usarticleattachments205806209Licenselocaiton.png
        Now that you know the name of the group, check the number of members en-usarticleattachments205341285Members.png

    1. AD user or Group - In case the user is not part of the AD group you defined during the installation of the On-Premises application server as the authorized group of admins which can login to ControlUp, you will receive this error.

      To verify the user you logged in with to windows and tried to launch ControlUp with, follow these steps:

      • Verify which user you are logged in with -

        en-usarticleattachments2052987491.png

      • Verify the the group you chose to use and its members as mentioned above in License Issue solution.
      • Make sure the group is types global and not universal

      In case the group was changed manually in the settings file and only the name was changed and not corresponding SID number, you will receive this error.

      • To verify the group and SID, please follow the steps mentioned above in License Issue solution.
    1. Setup Issue - The authentication method in the IIS is incorrect.

      To verify the authentication defined for the On-Premises ControlUp site, follow these steps:

      • Open the IIS manager on the On-Premises server
      • Under the ControlUp site click on Authentication
      • Verify that Windows Authentication is the only one Enabled
      • en-usarticleattachments205341725AuthenticationIIS.png

        en-usarticleattachments205341765WindowsAuthenticationOnly.png


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