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Can't Connect to Target Machine - Actively Refused
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Issue
You try to connect to an agent, but it fails with the following error:
"Could not connect to...The connection attempt lasted for a time span...target machine actively refused it"
Cause
The console tries to connect to an agent, but the agent service is down.
In addition, in Agent Deployment Settings, the Deploy agents automatically checkbox is disabled, so when you click connect, the console will try to connect, and if the agent service is down, it will fail.
Solution
In order to fix this issue, the Console needs to start the agent's service while trying to connect.
You can manually select Upgrade Remote Agent from Agent Control, or use the Deploy agents automatically option, to automatically try to restart the agent's service when you connect.
From version 9.0, the Deploy agents automatically option doesn't apply to monitors. If you select this option, the console still automatically deploys the agents.
If Deploy agents automatically is checked, the monitor might show high resource consumption. There are situations where there are many machines that the monitor can't connect to (network issue, server is down, etc).
In these situations, the monitor attempts to upgrade them repeatedly, which might use a significant amount of CPU\Memory.