vSAN columns are showing 0, N\A or ERR

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Issue

The vSAN counters columns in the Real-Time DX Console grid display values of 0, N/A, or ERR across all or multiple counters:
ERR shown in grid

Cause

Required permissions aren't properly set.

Solutions

"N/A" is displayed

  • Issues connecting to vCenter through PowerCLI
  • Check if PowerCLI 10.1.1.x or higher is installed

"ERR" is displayed

  • Turn on the vSAN performance service
  • Set storage.View permission to vCenter user

"0" is displayed

  • Turn on the vSAN performance service
Assistance needed?

If the permissions are set correctly and the issue persists, contact us at support@controlup.com