Error connecting to Azure subscription: An error occured in authentication or authorization. Make sure the resource provider has been registered with this subscription

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Issue

Connecting to the Azure subscription in ControlUp throws the following error:

{"code":"message":"An error occured in authentication or authorization. Make sure the resource provider has been registered with this subscription"}

Root Cause

To connect your Azure subscription to ControlUp, you must register the Microsoft.ResourceHealth provider.

Solution

  1. In the Azure portal, navigate to the left-hand menu and select Subscriptions.
  2. Select the subscription you want to connect to ControlUp.
  3. On the left-hand menu select Resource Providers.
  4. In the list of available providers, make sure Microsoft.ResourceHealth is Registered, as shown in the screenshot below.
    If the provider is not registered, select the provider and click Register.

 Resource Providers screen with Registered selected