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How to prevent vCenter excessive logging
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Issue
When monitoring host environment, there is logging activity made by ControlUp. In some cases it might cause the ESX logs to grow.
Cause
ControlUp Real-Time Console / Monitor login to the vCenter and retrieve the hypervisor information and then logs out. The login / log out process occurs about every 5 seconds.
Solution
You can change the connection to the hypervisor to be persistent.
To define persistent connection to the hypervisor, first define a data collector:
In the ControlUp Real-Time Console, right-click the hypervisor and select Connections settings
By default any ControlUp Real-Time Console / Monitor will connect to your hypervisor. To save bandwidth, you can set up a relay or data collector.
Remove the Console / Monitor and choose one of the agents to be the data collector.
In the example above, LVSITARGET03 collects the data and all consoles and monitors connect to that agent, to retrieve hypervisor performance metrics data (rather than the default console/monitor data collector).
- Set a persistent connection between the agent and the hypervisor, by editing the registry of the agent's endpoint and creating the following key:
HKLM\SOFTWARE\Smart-X\ControlUp\Agent\vmDataCollector
Then create a new DWORD value named vCenterPersistentConnection and set the value to 1 (0 = default mode / 1 = persistent mode).